Deliverability to icloud.com email addresses
Incident Report for Signable
Resolved
We have yet to hear anything from Apple however all emails sent to icloud.com email addresses are now being delivered successfully so we will mark this incident as resolved.
Posted over 1 year ago. Mar 12, 2018 - 09:50 GMT
Update
We haven't yet heard back from Apple however not all emails sent to iCloud email addresses are being blocked. We are seeing about 50% being blocked however since 5.34pm we haven't seen any being blocked. This may have been fixed by the iCloud team however we haven't heard anything so will still keep this incident open.
Posted over 1 year ago. Mar 09, 2018 - 17:55 GMT
Identified
We have identified an issue delivering emails to icloud.com email addresses. We have contacted Apple, to try to resolve this. This started happening from 2.03am this morning.
Posted over 1 year ago. Mar 09, 2018 - 13:51 GMT