Issue downloading envelopes
Incident Report for Signable
Resolved
This incident has been resolved.
Posted about 1 year ago. Mar 22, 2018 - 09:09 GMT
Monitoring
A fix has been deployed and we are seeing envelopes now being downloaded as expected. Continuing to monitor to make sure its fixed.
Posted about 1 year ago. Mar 22, 2018 - 08:15 GMT
Investigating
Investigating issues downloading envelopes which are also affecting signed envelope emails.
Posted about 1 year ago. Mar 22, 2018 - 07:54 GMT