Incoming phone calls
Incident Report for Signable
Resolved
This incident has been resolved.
Posted 3 months ago. Jul 12, 2019 - 09:21 BST
Identified
We are currently having issues with receiving incoming phone calls and all calls are being redirected to our overflow contact centre. Emails are the preferred method at the moment, please email help@signable.co.uk for any assistance whilst we resolve this issue.
Posted 3 months ago. Jul 11, 2019 - 12:05 BST