Release of new platform
Incident Report for Signable
Resolved
This incident has been resolved.
Posted 3 months ago. Jul 23, 2019 - 18:35 BST
Update
We are continuing to make improvements and fix bugs where they are cropping up.
Posted 3 months ago. Jul 17, 2019 - 16:33 BST
Update
We hear your feedback, both positive and negative and are working on making improvements and fixing bugs as soon as possible. We really appreciate your patience whilst these teething issues are worked out.
Posted 3 months ago. Jul 11, 2019 - 09:59 BST
Update
We are working through all of your feedback, comments and issues and are constantly improving the experience. We are sorry for the issues that some people may be having, specifically around page elements and random error messages. We are working on getting the outstanding issues fixed today but really appreciate your patience whilst we are getting everything fixed up.
Posted 3 months ago. Jul 10, 2019 - 13:53 BST
Identified
We have released the new platform and are experiencing a few teething issues but nothing major. Please take a look at our help site at https://signable.help/ for any assistance on how to use the new platform.
Posted 3 months ago. Jul 10, 2019 - 09:54 BST