Investigating - Degraded performance - Web App, API

Incident Report for Signable Status Page

Resolved

This incident has been resolved.
Posted May 26, 2026 - 09:01 BST

Update

This incident has been resolved.
Posted May 26, 2026 - 08:59 BST

Investigating

We are investigating an issue impacting the the Web App and API where customers are experiencing degraded performance. We will share an update as soon as we have more information. Thank you for your patience.
Posted May 26, 2026 - 08:43 BST
This incident affected: Web App and API.