Issues loading, sending and adding documents
Incident Report for Signable Status Page
Postmortem

On 9th October 2023 Signable suffered a significant outage. It was caused by a variable not updating correctly in older parts of the system, causing them to fail. The incident lasted roughly half an hour before normal service was resumed, but the failures in our older systems caused some envelopes altered during that period to become corrupted. As a result, these envelopes either did not send, can not be completed or can not be downloaded. We apologise for the inconvenience caused and are working hard to prevent this disruption in the future.

To address this, we are modernising our infrastructure, particularly in the areas affected by this outage. Over the next few months, we hope to see vast improvements. Concerning this incident, there will be two significant improvements:

  1. The new systems are much more resilient making incidents like this much less likely, if not impossible.
  2. Services will be broken down into smaller processes, with the ability to replay each of those processes in case of errors or incidents, allowing us to prevent unsent envelopes or other long-term disruptions.

If you have further questions or require more information, please get in touch with us at help@signable.co.uk.

Posted Oct 30, 2023 - 15:21 GMT

Resolved
We can confirm that our monitoring is showing that the issues impacting document processing have been resolved. If you continue to experience problems please contact our support team hello@signable.co.uk. Thank you for your patience.
Posted Oct 09, 2023 - 12:56 BST
Monitoring
We have implemented a fix for the issues with document processing and are monitoring the situation. The service is now recovering. We will share an update as soon as we can confirm it has been fully resolved. Thank you for your patience.
Posted Oct 09, 2023 - 12:51 BST
Identified
We have identified a fix for the issues affecting document processing. We’re working to implement it and will let you know as soon as it is deployed.
Posted Oct 09, 2023 - 12:47 BST
Investigating
We are investigating an issue impacting the upload of documents. We will share an update as soon as we have more information. Thank you for your patience.
Posted Oct 09, 2023 - 12:40 BST
This incident affected: Web App, API, and Document Processing.