Stripe outage potentially affecting some Signable Accounts
Incident Report for Signable Status Page
Resolved
This issue has now been fixed by Stripe and any affected plan renewals have now been processed.
Posted Jun 03, 2023 - 07:36 BST
Update
We are continuing to monitor for any further issues.
Posted Jun 02, 2023 - 21:20 BST
Update
We are continuing to monitor for any further issues.
Posted Jun 02, 2023 - 21:19 BST
Monitoring
Due to an outage with Stripe, our billing provider, some Signable accounts that are auto-renewing their plans whilst this outage is ongoing may experience issues sending envelopes.
If you are experiencing issues, enabling overages will resolve this.
Posted Jun 02, 2023 - 17:52 BST
This incident affected: Stripe API.