Unable to send envelopes via the public API
Incident Report for Signable Status Page
Postmortem

Thanks for your patience whilst we rectified the issue yesterday, to give you a little more information about what happened and how we will prevent it from happening in the future, here is the breakdown. 

What happened? 

Between the hours of 11:15 am and 12:30 pm on Thursday 12th May 2022, a subset of Signable API users encountered a server 500 error when trying to interact with it. 

The event was triggered by a change first deployed at 10:27am, a failure in the automated deployment process meant that not all code was deployed as expected. 

The issue was detected within a minute of deploying and the team immediately proceeded to manually intervene and force a full re-deploy which reverted the code changes to get the system back to its original state. 

What are we doing about this? 

We’re bolstering the automated deployment routine to make sure all deployment tasks are fully integrated.

If you need any more information get in touch.

Posted May 13, 2022 - 09:36 BST

Resolved
We saw elevated error rates on the public API starting at 11:15am today and implemented a fix straight away. Our monitoring is showing that the issues have been resolved. If you experience problems please contact our support team. Thank you for your patience.
Posted May 12, 2022 - 11:59 BST
This incident affected: API.