Resolved - Envelopes not showing on dashboard
Incident Report for Signable Status Page
Resolved
We can confirm that our monitoring is showing that the issues impacting viewing envelopes in the web application have been resolved. If you continue to experience problems, please contact our support team hello@signable.co.uk. Thank you for your patience.
Posted Sep 07, 2023 - 13:58 BST
Identified
We have identified a fix for the issues affecting envelopes not showing on the dashboard. [We’re working to implement it and will let you know as soon as it is deployed.
Posted Sep 07, 2023 - 13:38 BST
This incident affected: Web App.