Some customers receiving duplicate emails for envelope sending notifications
Incident Report for Signable Status Page
Resolved
This incident has been resolved.
Posted Sep 02, 2021 - 11:55 BST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 02, 2021 - 10:59 BST
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 02, 2021 - 09:59 BST
Update
We are still investigating the issue however there is no other impact to any other parts of the system, for example, envelopes are only created once.
Posted Sep 02, 2021 - 09:39 BST
Investigating
We are currently investigating this issue.
Posted Sep 02, 2021 - 09:17 BST
This incident affected: Email.