Degraded performance in the App
Incident Report for Signable Status Page
Postmortem

What happened?

On Monday 13th November, starting at 11:23am and resolved at 12:16pm our app and internal API experienced degraded performance due to an issue with our cloud provider’s (AWS) compute capacity. We didn’t experience any data loss or corruption during this time, just slower than normal service.

Our auto-scaling could not scale up to meet the demand therefore, we provisioned more resources manually.

Our cloud provider resolved this issue within minutes.

What are we doing about this?

We’re investigating solutions to ensure we always have enough capacity to meet demand, even if auto-scaling fails.

Posted Nov 14, 2023 - 09:02 GMT

Resolved
We can confirm that our monitoring is showing that the issues impacting loading in the app have been resolved. If you continue to experience problems please contact our support team hello@signable.co.uk. Thank you for your patience.
Posted Nov 13, 2023 - 12:16 GMT
Monitoring
We have implemented a fix for the issues with the loading of the app and are monitoring the situation. We will share an update as soon as we can confirm it has been fully resolved. Thank you for your patience.
Posted Nov 13, 2023 - 12:07 GMT
Investigating
We are investigating an issue impacting the loading of the app. We will share an update as soon as we have more information. Thank you for your patience.
Posted Nov 13, 2023 - 12:01 GMT
This incident affected: Web App, API, and Document Processing.