Delay in envelopes displaying in the dashboard
Incident Report for Signable Status Page
Postmortem

On May 22, 2024, starting at 14:44 UTC, our system experienced a significant issue where envelopes were not visible to users after being sent. This incident was also caused by a spike in ElasticSearch indexing latency, which led to job queues filling up faster than they could be processed. Thanks to the improvements made the previous day, the impact was not as severe. 

Additional manual scaling of the infrastructure returned latency to normal levels. By 19:15 UTC all job queues were fully processed and normal service resumed. 

During our investigation, we identified the cause of the increased latency to be the ElasticSearch service being throttled after we hit our throughput limit. 

Customer Impact

The incident resulted in the following:

  • Delayed syncing to ElasticSearch meant there was a delay before updates to envelopes were showing on the “envelopes” view in the web app.
  • Slow processing of bulk sends.
  • Delayed envelope expiries and reminders.

This affected 75% of new envelope requests, leading to significant user inconvenience and delays in processing.

Lessons Learned and Improvements

Preventive Measures:

  1. Infrastructure Changes: Upgrade the ElasticSearch data node types to improve performance.
  2. Dedicated resources for ElasticSearch: Give ElasticSearch more dedicated resources so it does not have to contend with other services. This will ensure that in the event of a latency issue, the impact is isolated.
  3. Enhanced Scaling Mechanisms: Implement enhanced auto-scaling procedures for all critical services.
  4. Alerting and Monitoring: Set up additional alerts for when message queues exceed predefined thresholds.
  5. Improvement in Job Management: Prevent job duplicates to reduce queue size during slowdowns.

We apologise for the inconvenience caused; we are proactively addressing the design of our infrastructure as we grow and appreciate your understanding as we continuously improve.

For any further questions or concerns, please contact our support team at help@signable.co.uk

Posted May 28, 2024 - 11:29 BST

Resolved
This incident has been resolved. Envelopes sent are now immediately visible afterwards. A full report will be published as soon as we have finished investigating the root cause. Thank you for your patience.
Posted May 22, 2024 - 20:01 BST
Monitoring
We have implemented a fix for the data processing delays and are monitoring the situation. We will share an update as soon as we can confirm it has been fully resolved. Thank you for your patience. A full report will be published as soon as we have finished investigating the root cause.
Posted May 22, 2024 - 19:00 BST
Investigating
We are investigating an issue impacting the dashboard. When an envelope is sent, there is a delay is displaying the sent envelope there. There is no impact on sending or signing envelopes identified yet. We will share an update as soon as we have more information. Thank you for your patience.
Posted May 22, 2024 - 17:19 BST
This incident affected: Web App.