Investigating - Downloading completed envelopes not working for some customers
Incident Report for Signable Status Page
Resolved
This incident has been resolved.
Posted Mar 30, 2023 - 08:11 BST
Monitoring
We have implemented a fix for the issues with the download links and are monitoring the situation. We will share an update as soon as we can confirm it has been fully resolved. Thank you for your patience.
Posted Mar 29, 2023 - 15:46 BST
Identified
We are investigating an issue impacting some customers who are experiencing issues downloading the completed envelope. We will share an update as soon as we have more information. Thank you for your patience.
Posted Mar 29, 2023 - 15:36 BST
This incident affected: Web App.